Failed to import user stories

Jan 12, 2011 at 3:51 PM

I am trying to use the tool to import user stories from an excel workbook. I have everything setup fine, but when I do the migration, I always get "Some error occurred during migration of work items". And in the details is says that none of the test cases could be migrated. Is there anyway to get more information on the failure so that I could attempt to correct it?

 

 

Thanks,

Anthony

Jan 12, 2011 at 5:21 PM

I would suggest running the tool using the VS 2010 debugger to see were the error occurs.   This is the approach I took.

Jan 12, 2011 at 7:39 PM

Do you know which source file I would find the method behind the "Save and migrate" button. I'm not having any luck finding it.

 

Jan 12, 2011 at 7:42 PM

If you run the import tool using the IDE via F5 or the Attach to Process, it should break on the error in the source.   You should then be able to walk back up the stack to the button handler if you need to.

Jan 13, 2011 at 4:46 PM

Ok, I've traced through the code and I think I know where the problem it. It is having a problem setting the columns. In the method SetSetparatingColumns(), m_selectedHeadersToColumn variable is being popluated, but the m_seperatingColumns is not. This is because it only has values added when the kvp.Value is mandatory. Is this something that is set in the workbook?

When it gets to doing the migration and call GetNextWorkItem(), which in turn calls ResetPointerToNextWorkItem, there is nothing in m_seperatingColumns  so it just keeps incrementing m_currentRow until it is greater then m_lastRow and does nothing.

Does my workbook need to have something done to it to get it to work with the tool?

Jan 13, 2011 at 5:32 PM

The best advice I can give you is to look closely at the sample spreadsheets to make sure you excel workbook is formatted correctly.   One issue I ran into was tht I did not have spacer rows between the Test Case records I was importing.